Why won't this 156 start then?? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Bert Cheese
Status: - Update
Posts: n/a
Help Why won't this 156 start then??

I'm asking this on behalf of a beleagured 156 TS owner........
.. The car will not start at all as the immobiliser appears to be on permanently,when the key is turned all the dash lights come on and stay on but the engine will not fire.
.....Also when trying to lock the car remotely via the key fob the alarm beebs once and locks,then again and unlocks.....all doors,boot and bonnet are securely shut though
.......Any clues chaps?,I've suggested he tries resetting the ECU,the alarm system has no isolation key on UK models either so the blokes stuck with a non starting Alfa and I've been asked for advice as I'm always telling people how wonderful they are
Sponsored Links
Status: - Update
Posts: n/a
Re: Why won't this 156 start then??

i have had the same problem ,

try this

first (easy option) replace the car battery i have been told that if the battery is slightly down then it has not got the power to read the key

second (this was my fault) unscrew the steering column covers and on the end of the ignition barrel is a plastic circular collar. gently pull it lose (carefull with the connecting wire!!) and while you have the key in the ignition move the pick up collar nearer the key then turn the igition on. if its the collar pick up that faulty the reduced distance may activate the the immobilser. (try several combinations and be patient)try replacing that collar anyway they are apparently prone to failure!!!

p.s. just trace the wire from the pick up collar to make sure its still plugged in!!!!

good luck!! and smile its all part of owning a 156!!!

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome