air con on my 156 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 29-01-11 Thread Starter
Status: -
AO Member
Join Date: Jan 2011
Location: United Kingdom
County: Kent
Posts: 71

Member car:

156 2.5 v6 1998

Help air con on my 156

The air con on my 156 appears not to be working, the operating light illuminates, quick fit charged the system and reported no leaks, but the compressor appears not to engage, is there a quick fix or an expensive repair.
ricksatluz is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,997
Connect AlfaDiag or FiatECUScan and check that the ECU can trigger the A/C compressor clutch.
If that works, it probably points to a pressure or pressure sensor problem.
David C is offline  
Status: -
AO Member
DB600's Avatar
Join Date: Nov 2006
Location: United Kingdom
County: Aberdeenshire
Posts: 35
Images: 14

Member car:

156 SW GTA

Hiya ricksatluz,
I've got the same problem & am working through it..slowly, I just never seem to have time
Some useful tips to try in this thread
DB600 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , air , con

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome