Auxiliary belt and alternator pulley failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 27-01-11 Thread Starter
Status: please help so wife will let me keep the alfa!!
AO Member
Join Date: Nov 2010
Location: United Kingdom
County: Berkshire
Posts: 24
Auxiliary belt and alternator pulley failure

Have tried a little search but I'm only on my brothers iphone. Please forgive me if this has been dealt with before.

Last night my auxiallary belt snapped and caused a fire! Anyway that fortunately caused minor damage but the small pulley at the back that is for the alternator has come off, I fear this means it is a major job. Please could someone advise and also a picture of how the new belt wraps around the pulleys would be helpful!
bradleyboy87 is offline  
Sponsored Links
Status: Work In Progress
AO Member
Dr Nahid Khan's Avatar
Join Date: Sep 2010
Location: United Kingdom
County: Surrey
Posts: 31

Firstly it isn't too major a job. I've just had mine fixed. Basically my belt was wearing out so i had it changed. but the pulley was the reason it was wearing out - something that wasn't detected at the time. A couple of weeks later the belt snapped and I lost the power steering whilst driving - to cut a long story short, the belt was replaced under warranty but again within a couple of weeks the same thing happened. My mechanic - Oscar from McFarlane Automotive - a top chap and awesome mechanic - did some deeper checking and found that the pulley had worn out and was moving slightly which was causing the belt to slip off and/or shredding part of the belt.

Now i'm not sure if it's the alternator pulley, but suspect it might be because i got the battery charge warning on the centre display

Hopefully it's been sorted now but could be a major issue if this happens again, i'm keeping my fingers crossed.

any luck with yours?
Dr Nahid Khan is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

aid , alternator , auxiliary , belt , failure , pulley , snapped

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome