Gearbox problem selespeed 147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 23-01-11 Thread Starter
Status: -
Join Date: Jan 2011
Location: South Africa
County: Gauteng
Posts: 2
Wave Gearbox problem selespeed 147

Is there anyone that can assist me, i have a alfa romeo 147 selespeed, the car only gets second gear, all happend after we washed the engine, all the plugs and senors are dry, and the diagnostic machine shows zero faults.
lorealelee is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
VERY bad idea to have washed the engine, but I guess you know that now!!

Have you treated ALL the connectors on the Selespeed actuator and the big multiplug plus the relay?

If not, get some good contact treatment (ie Electrolube EML), unplug them all and treat them.
David C is offline  
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Check the connection to the speed sensor on the front of the gearbox. If that's disconnected/dirty/faulty it won't go above 2nd.'s a generic limp-home default IIRC, so it could be a number of things....
iainfm is offline  
(Post Link) post #4 of 4 Old 24-01-11 Thread Starter
Status: -
Join Date: Jan 2011
Location: South Africa
County: Gauteng
Posts: 2
Thank you all for advice, will try, and let you know.
lorealelee is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , gearbox , problem , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome