147 stereo setup help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 22-01-11 Thread Starter
Status: -
Join Date: Jan 2011
Location: United Kingdom
County: Berkshire
Posts: 9
Images: 2
Help 147 stereo setup help

hi there guys I have just got a new Alfa Romeo 147 facelift model (2008) and was wondering if you could help me with the stereo setup, I’m looking to replace the speakers, tweeters and add a subwoofer to the car as it lacks that bass sound that I like when listening to music, and I’m after a bit of help as I am clueless when it comes to car audio as this will be my first time changing the car stereo.

so this is what I wanted to do firstly I wanted to add a 4 pioneer 17 cm TS-E1702is the (280w) ones in to the doors but I’m not too sure if I need any adaptors. I wanted to buy the kit but was wondering if the tweeters will fit into the doors as pioneer say they fit the car but the tweeters are 28mm and the old ones are 25mm TS-E170Ci 17cm Separate 2-Way Speaker System (260W) - Pioneer Speakers & Subwoofers

also I wanted to fit a subwoofer in the car to add a bit of bass, I was thinking of getting one that fits into the spare tyre but, after looking around I found a Bose sub with box and the amp built for the 147, I was wondering if there are any complications to doing this and if a Bose sub can be added to an aftermarket set up.

also I know I need to get an amp and was wondering if this amp would be up to the job GM-D9500F Four Channel Class-FD Car Amplifier (800W) - Pioneer Amplifier (pioneer GM-D9500F.)

also do I need a separate amp for the sub of can I use the Bose one also can all this be hooked up to the existing stereo until I get chance to replace it. Also do I need to be replacing any of the wiring.

thanks guys sorry if I put this in the wrong place.

Last edited by jamesk1; 22-01-11 at 13:54. Reason: wrong info
jamesk1 is offline  
Sponsored Links
Status: seize the moment, not the engine
AO Member
ciarant's Avatar
Join Date: Apr 2009
Location: Ireland
County: Dublin
Posts: 222
You might want to move this thread to the ICE lounge for better advice
ciarant is offline  
(Post Link) post #3 of 3 Old 22-01-11 Thread Starter
Status: -
Join Date: Jan 2011
Location: United Kingdom
County: Berkshire
Posts: 9
Images: 2
jamesk1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , setup , stereo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome