brake fluid and hand brake warning - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 11 Old 17-01-11 Thread Starter
Status: -
AO Member
Join Date: Nov 2007
Posts: 16

Member car:

alfa romeo 156

brake fluid and hand brake warning

Hi all, would be grateful if you can explain why am getting intermittent warning message; low brake fluid or hand brake on when i negotiate a bend or climbing while driving. I have checked the brake fluid reservoir and seem to be full. The question is am I checking the correct reservoir which is on the engine bay? Can someone please tell me the exact location of the brake fluid or why am getting these warning message. Thanks in advance.
cool2004 is offline  
Sponsored Links
Status: DEFCON5
AO Gold Member
1of1's Avatar
Join Date: Oct 2010
Location: Sao Tome and Principe
County: Principe
Posts: 11,605
Images: 7
Could be low pad material warning
1of1 is offline  
Status: Enjoying a nice mug of tea
AO Silver Member
Join Date: Oct 2008
Location: United Kingdom
County: Bedfordshire
Posts: 1,752
I had something similar when I first got my Alfa - it turned out to be the fluid level sensor was sticking and giving a false reading, we replaced the lid on the break fluid (which contains the sensor) and all was well again.
CJO is offline  
Status: Wondering why people buy so many Audis
AO Silver Member
Quadrofoglio's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: West Yorkshire
Posts: 1,225
Common fault on 2002 onwards 156s from new. As long as the level in the brake fluid reservoir is OK just ignore it!
Quadrofoglio is offline  
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
Make sure the handbrake is properly off too.

It is wrong to just ignore an error message.
They are there for a reason and won't just appear without something being wrong.
David C is offline  
Status: -
AO Silver Member
Join Date: Aug 2003
Location: Bristol
Posts: 5,002
I don't know which 156 you've got so can't be sure where the reservoir is- but normally if you take the lid off (carefully to avoid getting muck in) there's a screen just inside.
mave is offline  
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,862
It might be the brake pad wear indicator. Its just a bare wire embedded into the pad material. When the pad wears down enough the wire touches the disk and turns the light on. On several cars I've found that these wires have simply come out of the pad and were randomly touching bits of metal and turning the light on. It might also have chaffed against something metal.
Rockhopper is offline  
Status: Alfa-less
AO Member
torque's Avatar
Join Date: Nov 2010
Location: United Kingdom
County: Durham
Posts: 468

Member car:


I have this on my 1999 156, only happened 3 times in the last 2 months. Fluid level ok and handbrake off, i knew it was a duff sensor when the light went out after tapping the little rubber cover on the reservoir cap a few times and the light went out

One of those little quirks.

I think the pad wear warning light is different, red circle with dotted outer lines
torque is offline  
Status: - Update
Posts: n/a
Mine always comes on in the snow (as does the ABS light). Turn the car off and when you restart it returns to normal. I suspect Bill Gates' involvement.
Status: Alfa-less
AO Member
torque's Avatar
Join Date: Nov 2010
Location: United Kingdom
County: Durham
Posts: 468

Member car:


Originally Posted by keithyboy View Post
I suspect Bill Gates' involvement.
torque is offline  
Status: 120 of the finest italian horses
AO Member
nick9one1's Avatar
Join Date: Oct 2009
Location: United Kingdom
County: Lincolnshire
Posts: 362
Images: 4
Mine used to come on in the snow, the handbrake cables froze and you couldn't release the handbrake fully. £25 for two new cables and its good as new!
nick9one1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

brake , fluid , hand , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome