My 147 just made me poop! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 13-01-11 Thread Starter
Status: -
AO Member
panchogw's Avatar
Join Date: Jan 2009
Location: United Kingdom
County: Surrey
Posts: 27

Member car:

147 2.0 LUSSO

Warning My 147 just made me poop!

So I'm driving along the A331 at 70mph with the cruise on and The Archers on on the radio and everything state normal..

Then suddenly the car starts swerving from side to side in and out of the lane. This goes on for about 5 terrifying seconds and then stops. Then I get a dash warning for VDC failure and ABS failure.

Anyway... I managed to get home without further incident. A cup of sweet tea and some new undercrackers later I consult the fuse diagram in the handbook. There's a 7.5 amp fuse in the control box under the steering wheel which looks after both VDC and ABS. Bingo I'll have a look. Pull the thing out and it looks fine so looks like an expensive trip to the dealer

It's only later when I thought I'd have another more careful look that I found that although the filament was still intact there was a slight rattle from the fuse and a tiny bit of movement in one of the connectors. After spending 2.50 at Halfrauds the problem appears to be sorted

Has this swerving thing happened to anyone else? It's scary that something as small as a fuse could have had such catastrophic consequences.

panchogw is offline  
Sponsored Links
Status: -
AO Platinum Member
156Chris's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Surrey
Posts: 12,877
Images: 12
Nope not had that happen ... I thought you were going to talk about the fact that that road is always getting flooded!!!
156Chris is offline  
Status: - Update
Posts: n/a
Kinda know how you feel. My car on several occasions has automatically slammed on the brakes at speed.

The only car i've owned where i'm paranoid of it doing it again (and that's been dangerous in this way), regardless if it's fixed, Alfa's & electronics don't seem to mix.

Lost a lot of trust in them tbh, can't really 'have fun' without wondering what's going to go next.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , made , poop

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome