thermostat advice - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 05-01-11 Thread Starter
Status: -
AO Member
mrmcox's Avatar
Join Date: Dec 2010
Location: United Kingdom
County: Lincolnshire
Posts: 19

Member car:

alfa 156 1.8TS

thermostat advice

hey guys...
Just after a little advice, Im not sure if my thermostat on my 156 1.8TS is knackered, or if its the sensor, or just the dash gauge...

After starting the engine and setting off, the heater takes a good 7 or 8 minutes to warm up, after this it seems as tho it works fine, however the temp gauge in the car never seems to rise up from 50-60, even in heavy traffic, I dont think i have ever seen it rise anywhere near the 90mark. I was just going to try changing the sensor see if that works....But do you think it would be better to change the thermostat aswell ?

Just a quick long should it take the heater to warm up on cold winter morning like we've been having in the UK recently ?

mrmcox is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,995
If it doesn't even rise above 60, even in heavy traffic and your heater is working nicely, then it could be a gauge or sensor issue.
Ideally you need it plugged into diagnostics to see what the ECU sees when the gauge is at 60 and also using a laser temperature sensor, what the actual temperature of the pipes at the thermostat are.
David C is online now  
Status: Back next year!
Regional Representative
For the South East - AOSE
PJ3074's Avatar
Join Date: Nov 2010
Location: United Kingdom
County: Kent
Posts: 2,421
Images: 15
PJ3074 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

advice , thermostat

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome