Alfa 156 JTS Temp - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-01-11 Thread Starter
Status: -
AO Member
Join Date: Nov 2009
Location: United Kingdom
County: Warwickshire
Posts: 31
Cheese Alfa 156 JTS Temp


I have a problem that the temp gauge is not working on my 156 2.0 JTS.
I have replaced the thermostat with one of my other alfa the im breaking but doesnt seem to fix it.
Have checked and the bottom hoses stay cold until it reaches 90 degrees but as soon as I pull off it starts going down and doesnt go back up until I stop.
Please help, I need to drive to london on tuesday.


jon156 is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,991
The stats don't always stick fully open.
Some are just slow to close, which will cause the temperature to drop when driving.
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , jts , temp

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome