Low engine coolant temperature - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Injected with a poison
AO Member
satanism's Avatar
Join Date: Sep 2008
Location: Denmark
County: Fyn
Posts: 970
Images: 10
I'd imagine an airlock would actually make it overheat....(90+) rather than the opposite...
I stil think the stat doesn't close when it needs to...
How fast does it warm up?...it should take no more than 2-3, max 4 miles for it to get to 90C unless it's freezing cold(say -20)
satanism is offline  
Sponsored Links
Status: -
AO Member
Cosmo156SS's Avatar
Join Date: Aug 2010
Location: I would rather not say
County: -
Posts: 436
Images: 2
Originally Posted by dlapwood View Post
Still having problems but of a different kind. Engine is now warming up well to 90c and dropping back but temperature is constantly fluctuating between 65-90c with no pattern to it. Bottom coolant hose stays cold until i rev the engine for a while but cools off again after a drive. I am pretty sure that it shouldn't fluctuate so much.
AFAIK this is normal behavior. The issue is that the gauge is "too responsive". Mine does the same, and reading the engine temp in Alfadiag it stays stable at 88-89℃.
Cosmo156SS is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

coolant , engine , low , temperature

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome