147 Selespeed concerns - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 28-12-10 Thread Starter
Status: -
Join Date: Dec 2010
Location: United Kingdom
County: Greater London
Posts: 8

Member car:

147 2.0

147 Selespeed concerns

Hi all,

I hope it's OK to ask and certainly hope I've posted in the right forum but I'm in the market for a 147 at the mo.

I was quiet happy just pottering around waiting until the right one came up and then started seeing threads in various forums about the selespeed gearbox.

These problems seem to range from gear selecting issues to failure messages on the dash etc. 6 years old 147's with under 50k on the clock with full service history to older models and everything in between seem to experience some sort of issue.

When I'm looking at a 147, can anyone shed some experience/light on any tell tell signs of a gearbox that's about to misbehave? Anything I can do when I'm test driving it to highlight potential problems?

Or would it just be safer to avoid the Selespeed model and opt for a tradition 5 speed manual?

Any tips, advice would be greatly appreciate and thank you
Eyoras is offline  
Sponsored Links
Status: -
AO Member
markmoto's Avatar
Join Date: Feb 2008
Location: United Kingdom
County: Merseyside
Posts: 729
Images: 24

Member car:

Various Alfa's

selespeeds arnt get a bad press they dont deserve, they just need the odd bit of maintenance to keep them working as they should, its usualy lack of knowlege or people fixing them that causes problems, take it for a test drive and check the clutch action is smooth on take off and all the gears engage quickly and smoothly and no whining noises or crunching also check no warning lights on dashboard obviously other than that buy it and enjoy it..
markmoto is offline  
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
I have a sele for 9 years now ! and no problems whatsoever, I use my alfadiag once a year to monitor settings and keep the Tutela reservoir topped !

Don't let the average mechanic anywhere near a sele !
rarebear is offline  
Status: -
AO Member
Join Date: Jun 2010
Location: United Kingdom
County: Surrey
Posts: 444

Member car:

147 selespeed

Thumbs up for a sele

see if you can get somone to recommend a local inde garage near you then you cant go wrong. double check the belts have been done and theres no odd noises eg. suspension creeks, selespeed pump wyne and make sure the wipers work firmly you should get one privatly for a decent .

good luck
antman147 is offline  
(Post Link) post #5 of 6 Old 29-12-10 Thread Starter
Status: -
Join Date: Dec 2010
Location: United Kingdom
County: Greater London
Posts: 8

Member car:

147 2.0


Thanks for the advice guys, I'll certainly keep them in mind when I'm checking out a car

Thanks again!
Eyoras is offline  
Status: - Update
Posts: n/a
had mine since march 02 plate great car check with laptop now and then no probs

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , concerns , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome