Selespeed Jerky After Overseas Trip - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 23-12-10 Thread Starter
Status: -
AO Member
Join Date: Jul 2005
Posts: 167

Member car:


Selespeed Jerky After Overseas Trip

After travelling overseas for about a week, when I started driving the GT JTS again, my selespeed felt jerky through the gear changes. After a day or two, things smoothen out. I did not disconnect the battery as I suppose a week isn't long enough to warrant that.

Anyway, is there a guideline as to how long we can leave the battery connected when the car is not in use? Also, could the jerky selespeed have anything to do with this?
trento is offline  
Sponsored Links
Status: -
AO Member
markmoto's Avatar
Join Date: Feb 2008
Location: United Kingdom
County: Merseyside
Posts: 729
Images: 24

Member car:

Various Alfa's

probably just things abit sticky/cold after being left for a week if its now gone away i wouldnt worry about it.
markmoto is offline  
Status: - Update
Posts: n/a
Sometimes my bella is left not driven for 2 or sometimes 3 weeks at a time and i never disconnect the battery,and its out on the drive in all weathers.As said i wouldnt worry too much.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

jerky , overseas , selespeed , trip

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome