156 overheating in -8 temperatures!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 22-12-10 Thread Starter
Status: -
Join Date: Dec 2010
Location: United Kingdom
County: -
Posts: 2
156 overheating in -8 temperatures!!

Hi...my 156 2.0ltr veloce x reg does`nt like these very cold days.When its around -8 my engine overheats and there is no heat from the blowers in the cab.When the outside temp rises the engine goes back to normal.Is this a thermostat problem?
booman is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
How good is your antifreeze...?
David C is offline  
Status: -
AO Silver Member
Join Date: Oct 2005
Location: Northumberland
Posts: 2,139

Member car:

P2 GTV 3.0

Check the coolant. Sounds like there is either very little or it is frozen. (Eek!!) Does it have antifreeze in it to correct strength?
SimonT is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , overheating , temperatures

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome