Frozen coolant and waterpump broken? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
RS232's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Wiltshire
Posts: 432

Member car:

Alfa 156 2.4JTD

I'm NOT saying that it can't happen what I trying to say is that if it freezes something bad is going to happen to the rad and/or engine.
I have seen a few engines that had cracks due to the water freezing inside the block.
RS232 is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
It can freeze and not crack anything.
David C is offline  
(Post Link) post #28 of 28 Old 23-12-10 Thread Starter
Status: -
AO Member
Join Date: Oct 2007
Location: United Kingdom
County: Essex
Posts: 261
Surely it would expand and release it's pressure on the the inlet pipe coming from the block, that would act as a type of pressure relief?
happybiker is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

broken , coolant , frozen , waterpump

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome