removing single use hose clips ? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-12-10 Thread Starter
Status: skint!
AO Silver Member
cannotstop's Avatar
Join Date: Aug 2009
Location: Ireland
County: Dublin
Posts: 1,197

Member car:

156 GTA & 156 Ti

removing single use hose clips ?

I tried to remove a thermostat on my car yesterday.

Made a mess of it. I removed the first big hose clip with difficulty, and then got stuck.
How am I supposed to remove the two small ones at the back ?

There is no space to maneuver, and the clips dont have any release system.

How do you do it ?
cannotstop is offline  
Sponsored Links
Status: On Alfa number 15
AO Platinum Member
symon's Avatar
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 33,572
Images: 13
Stick a small screwdriver through them and twist, or twist them with a pair of pliers.
symon is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clips , hose , removing , single

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome