whine / click click from warm engine... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-12-10 Thread Starter
Status: sellin the alfa :(
AO Member
pygmyarr's Avatar
Join Date: Jul 2010
Location: United Kingdom
County: Derbyshire
Posts: 245

Member car:

147 2.0l 3dr

whine / click click from warm engine...

she's a 2.0 147 52 plate, and blew a dipped beam bulb on a spirited back road blast just now, having changed one a few months back, didnt consider it that hard to do with a torch, but as i was turning ignition to MAR to check it's aim was remotely right, i heard a click click whine sort of sound coming from somewhere between the battery and the engine.

initially i thought it was the replacement bulb (factory fitted bulb from my knackered pug 406) was being a bugger for not being hooked up right, but closer aural inspection sourced it from the other side of engine bay.

it wasn't hugely loud, but loud enough to hear over the radio. (didnt have car turning over)... it did this routine of clicks n whines twice every time i clicked to MAR from off.

is it something bad like a powersteering pump failing? the waterpump failing? or could it be from my dicky thermostat (sound comes from that sort of area) trying to work again?

she didnt go into limp mode, had no warning lights (although i did have low oil pressure earlier today, for a split second as i made a sudden right to get through a 'toocloseforcomfort' gap in traffic) and is generally running well.

alfa ownership = dentist visit.
expensive, sometimes painful, but at the end of the you've got a perfect grin on yer face.
pygmyarr is offline  
Sponsored Links
Status: -
AO Silver Member
Alfafamily's Avatar
Join Date: May 2010
Location: United Kingdom
County: Warwickshire
Posts: 5,758
Images: 10
You might be hearing the stepper motor resetting itself. Have a listen around the throttle body. Its not a fault.
Alfafamily is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

click , engine , warm , whine

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome