rear window demister - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-12-10 Thread Starter
Status: -
AO Member
kilsby78's Avatar
Join Date: Nov 2010
Location: United Kingdom
County: Leicestershire
Posts: 188
Images: 12

Member car:

147 gta

rear window demister

hi need some help my rear window demister does not work plus the heated wing mirrors dont demist checked the fuse, had alook on here and one post says it could be a relay which is behind the gloove box so have taken the gloove box off and there is no relays behind it, when i press the button for the rear window demister carnt here a click which i had in my 2.0 ts ??? any help would be is 156 2.5 v6
kilsby78 is offline  
Sponsored Links
Status: Hey Joe...
AO Gold Member
iainfm's Avatar
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,271
Images: 5
Check the relays in front of the battery, and clean the contacts. Cured my demister problem (which wasn't the one I was trying to fix at the time!).
iainfm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

demister , rear , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome