Yet Another MAF question - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 10-12-10 Thread Starter
Status: No problems to report its all gravy
AO Member
steviec's Avatar
Join Date: Aug 2009
Location: United Kingdom
County: Cornwall
Posts: 381
Images: 2

Member car:

156 2.4jtd 20v

Yet Another MAF question

Evening people need to pick your brains a little. Past few days 1st thing we have had a real hard frost and when I start my car the do not collect 200 go directly to the dealer and have your pants pulled down light comes on, plug the old crap top in with Fiat ecu scan read the fault codes and it say "Poor air quality 2" or something along them lines. Well this morning no frost started the car and bingo no warning comes up. So I was wondering could the fault be with the MAF and maybe a bit of dirt and moisture freezing on the sensor that is chucking up the warning. Only puts the ecu light on the dash first time you start the car clear the error and thats the car fine for the rest of the day.
Oh and I think my EGR valve is sticking no black smoke but doesnt pull like it used to till 2200rpm then the turbo snaps your neck when it comes in puts a grin on my face when it happens but I know its not right lol
Please discuss

Cheers people
steviec is offline  
Sponsored Links
Status: -
Join Date: Nov 2010
Location: United Kingdom
County: Londonderry
Posts: 39

Member car:

alfa 147 t spark

yes its could be maf or a pipe ripped or dirt etc etc etc but i will check maf and the pipes around it to make sure thats ruled out or is the issue
was.alfa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

maf , question

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome