Engine management light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Engine management light


can someone please help me
i have a 51 alfa romeo twinsport , my dash says engine managment failure .....
Its started to stay on the dash now an keeps bleeping away at me....
This morning the car felt rather ropey to drive an sounded more like a motor bike then a car also felt jumpy like it was ready to cut out.....
Couple of weeks ago i went to halfords...they tested the battery for free and said buy rights the car shouldnt be working as it came up the battery was dead ?
Im frightend to drive it now....only had it four weeks max from a private dealer.

Ive been looking on ebay for code readers as itll probaly cost less then what the garage will charge .
I have no idea what one would work for my car as theres loads to choose from ..
Does anyone have an idea?
Also whats wrong with her ... Ive read it could be many things .

Thanks in advance
Sponsored Links
Status: - Update
Posts: n/a
Hi :wave: welcome to AO

As you are posting about a problem with you 147 I've moved your thread into this lounge where you'll get more of a response

Please feel free to go back to the Newbie section and post a hello thread and good luck with your problem
Status: Finally got a Brera
AO Platinum Member
Stu GTV's Avatar
Join Date: Oct 2009
Location: France
County: Languedoc Roussillon
Posts: 12,724
Images: 40
She has already PG...........http://www.alfaowner.com/Forum/alfa-...ent-light.html
Advised her to do that this morning and has already had the usual good advice from a few members......
Stu GTV is offline  
Status: cam sensor problem
AO Member
Join Date: Dec 2010
Location: United Kingdom
County: Cheshire
Posts: 28

Member car:

alfa 156 1.8

hi any ODB II scanner should do mine was 30 quid of ebay (the orange one)
bidster73 is offline  
Status: Injected with a poison
AO Member
satanism's Avatar
Join Date: Sep 2008
Location: Denmark
County: Fyn
Posts: 970
Images: 10
the dead battery might be the source of your troubles
satanism is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , light , management

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome