Revving - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 07-12-10 Thread Starter
Status: -
Join Date: Nov 2010
Location: United Kingdom
County: Leicestershire
Posts: 6

Member car:

156 t spark

Hmmm Revving

my 156 is still in the garage after it stated revving on it's own. Now after having a maf air flow meter, an idle air control,crank shaft breather,lambar sensor, checked for air leaks and had the throttle body cleaned, been looked at by 5 mechanics they now say i need a new engine??? Don't know what to do now, any help greatly appreciated
j d denoon is offline  
Sponsored Links
Status: Nowt gone wrong with the Renault
AO Silver Member
Zoo's Avatar
Join Date: May 2009
Location: United Kingdom
County: Surrey
Posts: 4,674
have you done an ecu reset?
Zoo is offline  
Status: getting my shit together
AO Member
pingu's Avatar
Join Date: Feb 2010
Location: Sweden
County: Stockholm
Posts: 140

Member car:

156 TS SW

These 5 mechanics dont look at alfas alot I would assume. New engine..

Cant help you though my throttle cable stuck right by the housing once after cleaning.
pingu is offline  
Status: -
AO Member
Join Date: May 2010
Location: United Kingdom
County: Edinburgh
Posts: 87

Member car:

156 2.0 Ts

When you say revving on its own?Are the revs rising and then dropping and doing this over and over?
Carnie156 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome