Wits End!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 02-12-10 Thread Starter
Status: -
Join Date: Nov 2010
Location: United Kingdom
County: Merseyside
Posts: 2

Member car:

Alfa 147 jtd 8v

Wits End!!!


I have a alfa 147 jtd facelift on a 05 plate, which I bought about 6 months ago. Took a bit of a risk as it is a high mileage on now stands a 100K it had 93K when I bought it. It only had one service not recorded in the history and had had the cambelt done at 71K according to the history.

I have had a few problems along the way including black smoke at the dreaded MSCF light which I found was the EGR valve. But it now seems that the water pump has gone and I can't do anything over 40 mph with out the darn thing overheating.

Had it confirmed that the water pump has worn, priced it up and it will be in the region of 350 to fit new water pump and cam belt ect

I have just had it on the diag and the MAF sensor also appears to have failed

There also appears to be an excessive amount of oil in the air intake pipe after the MAF sensor and a rattle from the rear suspension.

But I still love the car as it is so much fun to drive when it occasionally behaves

As you can understand I feel a little shafted and am not sure whether it is worth the outlay on a 147 with this sort of mileage on or should I cut my losses.

any thoughts would much appreciated.

many thanks

John Joe 147 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Aug 2009
Location: Slovenia
County: -
Posts: 436

Member car:

AR GT 3.2V6

AFAIK 100k miles is about 160.000km? Thats not really high mileage for a jtd.
Binji is offline  
Status: Injected with a poison
AO Member
satanism's Avatar
Join Date: Sep 2008
Location: Denmark
County: Fyn
Posts: 970
Images: 10
The oil after the MAF appears to be normal on pretty much every diesel.The reason for that is the engine ventilation...it's supposed to be just oil fumes, but with the time it builds up and goes down past the turbo and into the Intercooler.I bet if you open the hose entering your cooler there it will be all oily too.

As for the waterpump get it done ASAP as it can sieze and you'll just ruin your car...and better don't drive your car until you sort this out
satanism is offline  
(Post Link) post #4 of 5 Old 03-12-10 Thread Starter
Status: -
Join Date: Nov 2010
Location: United Kingdom
County: Merseyside
Posts: 2

Member car:

Alfa 147 jtd 8v

Yeah thanks guys,

Getting the work done as we speak.

yeah it works out about 160,000kms which is fine if its been looked after, but doing some closer inspection to be honest it's not a great example. I think I should have shopped around a bit more before committing to buy this one.

In that case could the excessive oil be due to the engine being overfilled as the oil level has been steady at maximum?
John Joe 147 is offline  
Status: -
AO Member
markmoto's Avatar
Join Date: Feb 2008
Location: United Kingdom
County: Merseyside
Posts: 729
Images: 24

Member car:

Various Alfa's

Oil from the turbo wont effect the maf as its before the turbo on the suction side not on the pressure side, they just get generaly dirty after awhile and need cleaning or replacing, 350 is a fair price for a cambelt and a water pump replacement.

Egr valves are very common i personaly think it should be part of one of the services and get cleaned say every 30,000mls it would sure solve alot of running problems developing.

As already mentioned 100k miles is not alot on one of these provided they have been serviced well, rest assured its not just alfas that have problems obviously once a car gets around 100k miles certain things will need to be cleaned or replaced, hope she provides you with some godo trouble free service after you get your belts and water pump done.

markmoto is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

end , wits

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome