Alfa 147 electric windows working on their own - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 29-11-10 Thread Starter
Status: -
Join Date: Nov 2010
Location: United Kingdom
County: Greater Manchester
Posts: 6

Member car:


Alfa 147 electric windows working on their own

Firstly, hello to all fellow Alfa owners. First post from a newbie.

I have a 2003 Alfa 147 1.6 Lusso which has an intermittent fault with the passenger side electric window.... it operates on its own! I.e driving along and it will start going down a bout an inch then a few seconds later it will go back up. Sometimes it goes down about half way then goes up. Sometimes it goes down and stays down until I intervene with the switch. Sometimes the switch doesn't work and you have to wait a few minutes.

Any advice would be apppreciated before I get an auto-electrician on the case.
on2wheelsand4 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , electric , windows , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome