Molyslip, slick 50? Any good? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 20 Old 25-11-10 Thread Starter
Status: -
AO Member
 
Exit Stage Left's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
Posts: 57
Crazed Molyslip, slick 50? Any good?

In previous cars I have used slick 50 or molyslip and it has made an instant change to the engine and the fuel consumption has improved. Has anyone used either in their Alfas or would you advise avoiding? I have a petrol 1.8 156 SW. Its on 64k and uses hardly any oil. I recently got just over 400 miles on a tank which included Welsh mountains and a full load. I checked the oil before and after and needed about 1/4 L to top it up. Considering that Alfas are designed to use oil and how heavy the car was and how steep some of the mountains were I was pleased with how little I had to put in.
Like I said in other cars they have been benificial but I have never tried any in an Alfa and I dont want to 'Upset' the engine.
Also what is the guidance on Redex etc
Thoughts, experience and opinions welcomed.

Thanks

Keith
Exit Stage Left is offline  
Sponsored Links
Advertisement
 
Status: Injected with a poison
AO Member
 
satanism's Avatar
 
Join Date: Sep 2008
Location: Denmark
Posts: 970
Images: 10
sorry, did you use 250ml of oil for 400 miles?


and by the way that thing with the "Alfas designed to use more oil" is a myth spread by those whose alfas burn oil like petrol...none of my alfas...or my italian cars has ever used more than half a litre between changes (6k miles)
satanism is offline  
(Post Link) post #3 of 20 Old 25-11-10 Thread Starter
Status: -
AO Member
 
Exit Stage Left's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
Posts: 57
Yeah, bought a 1L bottle and used less than half to top up. I was expecting some to have gone because of the weight involved and the steep inclines.
Thanks for clearing up a myth. Because so many people say they are designed to use oil you tend to think they know what they are talking about
Exit Stage Left is offline  
Status: Injected with a poison
AO Member
 
satanism's Avatar
 
Join Date: Sep 2008
Location: Denmark
Posts: 970
Images: 10
250ml for 400miles is not anywhere near "hardly uses" mate....As I said, had 4-5 italian cars, two of them alfas.My last TS used about a litre for 6000 miles...might want to go and get your car checked by somebody who knows what he's doing....
there are a few quite simple things that increase oil use...one of them was a dirty oil separator or something like that.not good at translating

allright had a look at the manual.
The oil consumption should be maximum 400ml over 620 miles...however I think thats not normal at all...
The only time when it should use a bit more oil is when new or if the engine has been rebuilt...and it needs to settle..


I've only used top quality oil in my cars though...either Castrol Magnatec or Motul X_cess 8100 both 5w40.

2004 156SW 2.4JTD M-Jet 20V
Currently: 189Whp@3850rpm / 410Nm@2400rpm

EX 1999 146 1.6TS 16V

Last edited by satanism; 25-11-10 at 19:35.
satanism is offline  
(Post Link) post #5 of 20 Old 25-11-10 Thread Starter
Status: -
AO Member
 
Exit Stage Left's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
Posts: 57
Going by the manual then its probably not that bad. I've only had the car a few weeks and (touch wood) its a goodun. I am going to get it serviced soon. It was supposed to have been done before I got it but you can never tell how much was really done. So once its been done by my tame mechanic I will have a better idea of what it actually uses.
I used to use magnatec all the time but I am sure I saw a post recently that said avoid it at all costs. Which I thought a little strange. Its good to know someone else uses it. I did consider the Alfa recommended but if Magnatec is worth using I will probably stick with it

Last edited by Exit Stage Left; 25-11-10 at 20:03.
Exit Stage Left is offline  
Status: Injected with a poison
AO Member
 
satanism's Avatar
 
Join Date: Sep 2008
Location: Denmark
Posts: 970
Images: 10
remember if you're doing the cambelt it should be done with the proper camlocks.
it's vital for any alfa to be maintained by somebody who knows alfas...
satanism is offline  
(Post Link) post #7 of 20 Old 25-11-10 Thread Starter
Status: -
AO Member
 
Exit Stage Left's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
Posts: 57
Luckily I shouldnt need that doing for a while as it was done about 10k ago. Unfortunately I have been spoiled for the last few years as I have had mainly Mercs. They never break down, never use fluids and when the service light pops on you book it in. If they werent so boring I would still have one. This Alfa is my first 'real' car for a long time. I actually look forward to finding excuses to go out in it. With the last Merc I couldnt be Arsed and let my wife do most of the driving. I had forgotten how much fun they are.............
Exit Stage Left is offline  
Status: belts, w/pump and cam sensor changed!
AO Gold Member
 
gazza82's Avatar
 
Join Date: Jan 2003
Location: United Kingdom
Posts: 7,648
Images: 12
You would think if these additives are so good .. they would already be in the oils ...

I'd leave it out ...
gazza82 is offline  
Status: None the wiser
AO Member
 
REDGAZ's Avatar
 
Join Date: Dec 2007
Location: United Kingdom
Posts: 725
Additives!?. None of them work!. Just use quality oil.
REDGAZ is online now  
Status: -
AO Silver Member
 
Photodave's Avatar
 
Join Date: Dec 2008
Location: United Kingdom
Posts: 2,012
I'm right there with satanism (now there's a phrase I never thought i'd use!). My 145 QV barely used a drop between changes and I drove it in a "quite spirited" fashion. There's a housing can leak on the belts side of the TS engine. I remember Peak Alfa spotting it on mine at cambelt change and fitting a new one for me. Just can't remember exactly what it was! Even then i was only getting a drip from it

Now I'm on the 2.4 20v diesel and that doesn't use much at all between 12k changes. maybe 1/2 Litre?

Oil additives are definitely not needed btw...
Photodave is offline  
Status: -
AO Silver Member
 
Alfafamily's Avatar
 
Join Date: May 2010
Location: United Kingdom
Posts: 5,755
Images: 10
They don't do any harm other than to your pocket. If you feel they have worked for you in the past then you should try them again. It could be that it affects your driving style for the better. That's often the case when people want economy devices or additives to work, they drive differently.
Alfafamily is offline  
Status: -
AO Member
 
Join Date: Sep 2010
Location: United Kingdom
Posts: 69
Additives...absolute waste of money!
T4hir is offline  
Status: -
AO Platinum Member
 
Ralf S.'s Avatar
 
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 12,407
Images: 17
Additives contain viscosity modifiers so they were good when oil was made of dead dinosaur bones and tended to break down over 6000 miles.

New synthetic and semi-synthetic oils can last 12,000 miles easily and synthetics particularly are very resistant to being broken down.. so the need for additives is diminishing.

If you want your engine to always have oil that is in "brand new" condition, use synthetic oil or use semi-synthetic and change it every 6,000 miles instead of the recommended 12,000. It'll be better for your engine than "old" oil that's had additives added to it to boost it.


Ralf S.

No bullets for Chaingun..
Ralf S. is offline  
(Post Link) post #14 of 20 Old 27-11-10 Thread Starter
Status: -
AO Member
 
Exit Stage Left's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
Posts: 57
Ralf S
That certainly makes sense. I think I will leave the addatives alone and do as Satanism says and use Magnatec. Ive used it in the past and trust it. My car will probably end up getting an oil change every 3k as my annual mileage is only about 6k these days and I change it every 6 months.
Exit Stage Left is offline  
Status: -
AO Member
 
Join Date: Dec 2009
Location: United Kingdom
Posts: 977

Member car:

147 JTDM 16V

As I understand it Slick 50 and similar products are not oil conditioners rather they contain additives that are claimed to coat the metallic parts with a thin friction reducing coating. This is supposed to remain in place even after you change the oil. So the type of oil you use (synthetic or otherwise) doesn't really come into it so far as these additives are concerned. Having said that I used Slick 50 years ago in a Golf GTI and couldn't really see any improvement in performance, no reduced fuel consumption etc, just seemed like an expensive bottle of oily stuff. I never bothered with it again.
Alexie is offline  
Status: tucked up in garage
AO Member
 
renone's Avatar
 
Join Date: Jun 2006
Location: Surrey England
Posts: 546
Images: 3

Member car:

Spider S4

Having used Slick50 engine and gearbox additive in the past my observations are that that both appear to have worked in the sense of smoother gearbox operation and the engine appeared to initially run better. However there was a noticeable reduction in engine braking. The worst was yet to come. On re building the gearbox some 10k miles later I found congealed lumps of ptfe. Having owned the car for many years I knew nothing else had been added to the box. On rebuilding the engine the same was found. Internet searches showed that this is caused by a breakdown of the additive. Admittedly the car in question was a Scimitar GTE with the old Essex lump and an almost agricultural gearbox! My concern is that these lumps could easily block the oil passages in modern engines and gearboxes causing all sorts of grief. Since then I have never used additives only good quality oil. Most certainly on our old 147 I kept a close eye on the oil level. Usage over 12k was no more than 750ml. I agree that the higher oil usage by Alfa's is a bit of a myth and a modern properly serviced modern Alfa running on quality oil should use very little.
renone is offline  
Status: S/W ,gtv sold, Mito 1.3jtdm
AO Member
 
alfafanatic100's Avatar
 
Join Date: Mar 2010
Location: United Kingdom
Posts: 559

Member car:

156 sw / gtv

Agree, use good quality oil and change twice a year, as for oil usage my sportwagon uses much less than 30mls
every 6 months, and it is used daily and regularly rev past 5000, now on 55,000 miles and still pulls very well.
My Gtv is used once or twice a month and after owning it for nearly a year has been topped up once no more
than 50mls, and is on 65,000 miles, not all twinsparks burn oil...it's the luck of the draw it seems...
Thats using 5w/ 40 fully synthetic with no additives.
I think full history is vital and least amount of owners is important, pref female....
alfafanatic100 is offline  
Status: -
AO Member
 
Join Date: Dec 2009
Location: United Kingdom
Posts: 977

Member car:

147 JTDM 16V

How about some of this stuff:

Welcome to ACTIV8 Universal Friction Reducer.

No solid bits in it apparently ... but 30 quid for 250 ml !
Alexie is offline  
Status: None the wiser
AO Member
 
REDGAZ's Avatar
 
Join Date: Dec 2007
Location: United Kingdom
Posts: 725
Quote:
Originally Posted by Alexie View Post
How about some of this stuff:

Welcome to ACTIV8 Universal Friction Reducer.

No solid bits in it apparently ... but 30 quid for 250 ml !
Nearly wrecked my Triumph Vitesse gearbox with this stuff. If you research this product it's full of harmful chemicals they knew about 50 years ago. American court cases on 'additives' reveals all, Google it up.
REDGAZ is online now  
Status: -
AO Platinum Member
 
David C's Avatar
 
Join Date: Aug 2003
Location: London, England
Posts: 27,415
Just use a good quality oil and steer well clear of any extra additives.
David C is online now  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
good , molyslip , slick

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome