Alfa 147 2,0 radiator problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 22-11-10 Thread Starter
Status: -
Join Date: Nov 2010
Location: Norway
County: Telemark
Posts: 2
Hmmm Alfa 147 2,0 radiator problem

I have a problem with the cooling on my Alfa 147 2.0 Selespeed. The engine gets very hot. It smells burnt after driving some time (5-15min). If I pull out the oil dipstick smoke comes out. Previously the temperature gauge kept stable at about 90 degrees. Now it varies very much in start-up, but it never raises above 90 degrees. It may seem as if the radiator fan wont start. I have checked the fan and fan relay, everything OK.

I have noticed that the AC dont provide cool air I. Can that be associated with the problem that the radiator fan wont start?

Do anybody know what to do???


Last edited by Tomeliten4; 22-11-10 at 15:16.
Tomeliten4 is offline  
Sponsored Links
Status: up the country
AO Member
disimpit's Avatar
Join Date: Sep 2010
Location: United Kingdom
County: Northumberland
Posts: 106

Member car:

147 ts 2.0

You haven't said how many miles or age of the 147? Older cars do smell as seals and dirt etc wear and accumulate.

The radiator fan should still come on - even in northern climates at this time of year - if sat in traffic or under heavy use. Air con may not come on below 5C (I think) someone will confirm.

Smoke from the dipstick would be worrying and would be a sufficient reason to stop driving the car until the cooling has been checked - to avoid cooking the engine!
disimpit is offline  
(Post Link) post #3 of 3 Old 23-11-10 Thread Starter
Status: -
Join Date: Nov 2010
Location: Norway
County: Telemark
Posts: 2
Its a 2001 model. Anthe car has bin driven 110 000km.
Tomeliten4 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , problem , radiator

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome