Alfa 147 engine care and precautions??? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 22-11-10 Thread Starter
Status: -
AO Member
alfa147selesped's Avatar
Join Date: Jul 2010
Location: Mexico
County: Distrito Federal
Posts: 31
Alfa 147 engine care and precautions???

hi i got an 147 selspeed from 2004,(55k miles)

i want to know which parts i need to change to prevent engine damages (water pump, variator, cambelt, tensioners etc...????)

thanks for your help!!!
alfa147selesped is offline  
Sponsored Links
Status: -
AO Member
Join Date: Feb 2008
Location: United Kingdom
County: Cambridgeshire
Posts: 208
If those haven't been done you need to get all of those done as soon as possible (except for the variator if it isn't making a noise). If it was my car I wouldn't be driving it until it is done.
Betty_Swallocks is offline  
Status: Yes I'm back! hehe.
AO Silver Member
TheMystic's Avatar
Join Date: Feb 2009
Location: South Africa
County: Gauteng
Posts: 1,436
Images: 21
I assume it's 2L.

If so then, I'd do the below.
3 belts - Cam, balance and Aux. All with the associated tensioners and pulleys.
Water pump, see if you can get the metal impeller one.
2 sets spark plugs, the extra bucks for the proper ones is worth it as you only need to change every 100,000 KM.
Flush and replace all the coolant, and inspect cooling hoses and renew the thermostat if needed.
For the sele, get the clutch rod length checked and set if need be. Weekly check the fluid level. Otherwise leave it alone before you tempt fate.

On these cars you must do the weekly checks. Also use the best products (eg oil and coolant) you can afford or if you have favourite good brands.

Also, as said above, if these belts haven't been done yet in the car's history. I'd park it up till it's done, because you're on borrowed time. If the cam belt lets go, it over for that motor. I can't stress this enough.

edit: I now see it is the 2L.
Nice pic BTW.

Keithy says: "I think you put too much sugar on your cornflakes! "
TheMystic is offline  
(Post Link) post #4 of 4 Old 23-11-10 Thread Starter
Status: -
AO Member
alfa147selesped's Avatar
Join Date: Jul 2010
Location: Mexico
County: Distrito Federal
Posts: 31
hi and thanks for the answers, the belts have been changed at the 28k miles, about the wather pump it is necesary to change it??? the temperature is fine every time, and about the variator, it makes a sound in the cambelt like a brrr brrr, like a worn bearing i think that is the variator
alfa147selesped is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , care , engine , precautions

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome