Rear brake light flashes instead of indicator - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 21-11-10 Thread Starter
Status: -
Join Date: Nov 2010
Location: Ireland
County: Waterford
Posts: 1

Member car:


Rear brake light flashes instead of indicator

Hi All,

My drivers side rear turning indicator is not flashing. Some times the red light flashes instead of the indicator, sometimes it doesnt work at all. The warning light on the display flashes indicating a fault. The passenger side indicators are working fine. Any suggestions!


Garry Doyle is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,995
Usually an earth fault.
David C is offline  
Status: Yes I'm back! hehe.
AO Silver Member
TheMystic's Avatar
Join Date: Feb 2009
Location: South Africa
County: Gauteng
Posts: 1,436
Images: 21
+1 what he said ^^^
TheMystic is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

brake , flashes , indicator , light , rear

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome