engine temprature problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 10-11-10 Thread Starter
Status: -
Join Date: Oct 2010
Location: United Kingdom
County: Staffordshire
Posts: 9

Member car:

147 tspark

Help engine temprature problem

Hi can anyone help, my 147 ts 1.6 has a problem with the temprature guage, it barly goes above 50 degrees when drving, when idle or crawling along in trafic it goes ut to 80 but fluctuates up and down, would this be a temp sensor? if so where is it located on the car
cheers for your help just needed to know to order one off alfa
walsall terrier is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Jul 2004
Location: United Kingdom
County: Derbyshire
Posts: 5,586
It's your thermostat!
Dave Brand is offline  
Status: -
AO Member
Join Date: Oct 2010
Location: United Kingdom
County: West Midlands
Posts: 37

Member car:

Alfa 147

Yea my 2.0 is doing this and waiting to get a new thermostat fitted, just under the air feed pipe in the right hand side of the engine, its on the side, has three of four pipes going into it, the temp sensor is on top of it.

Mine will sit at 90 in trafic, but then will go down to 70 even 60!

If i dont let the car warm up first and drive right away, it dont move above 50 at all unless i stop in trafic, the engine being cooled to much is not good, but will be ok untill its changed.

Its a pain in the cold weather when you need heat!

Some Alfa site have them for 34 is the cheapist i have seen, e-bay they are 38 plus.

Only got two more weeks untill i can change mine! Good luck
DANMAXWELL is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
defo your stat. very common
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , problem , temprature

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome