1999 156 2.0TS water leak (not footwell!) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Madness 1999 156 2.0TS water leak (not footwell!)

I have a 1999 156 2.0TS. Where the oil filter screws on, two alloy pipes feed water in/out of the oil filter mount. I have been told this is a basic oil/water heat exchanger.

About 8 months ago, BOTH of these pipes sprung a leak. Each was a tiny pinhole right on the 'elbow' of the pipe right-angle. Both were patched up with metal repair paste then the whole part replaced.

Today, ANOTHER leak has sprung!! Exactly the same, a pinhole on the right angle.

Has anyone else seen this happen?

Sponsored Links
Status: - Update
Posts: n/a
Re: 1999 156 2.0TS water leak (not footwell!)

Hi Welcome to the forum Hope you feel a bit calmer after hanging around here for a while ......

Sounds like the same set up as earlier car and I've not heard of this before....can't remember reading about it on here either Very odd to have it happen twice


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 1999 , 20ts , footwell , leak , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome