rattle noise in engine after belt change - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 02-11-10 Thread Starter
Status: -
Join Date: Oct 2010
Location: United Kingdom
County: Essex
Posts: 1

Member car:

145 Cloverleaf

rattle noise in engine after belt change

hi guys i recently done the belts on my 147 1.6 2003 all went well except didnt have the cam locking tools so turned the cams so lobes face away from each other on first pot,put belt on,turned engine over twice-all good and well,went to start her up and she fired up on the button.

let her run for about 20 then gave her a little rev-THIS IS WHERE THE PROBLEM COMES IN-when you rev her at certain revs it gives off a funny grrr/rattle/flapping belt sound,so turned it off rechecked and tightened tensioner, started again and she was fine when revving,then turned off and started again and there it was again this grrrr/belt flapping noise at certain revs-

Any Ideas???????
RSA Alfa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

belt , change , engine , noise , rattle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome