147 Strange Light Activity! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 01-11-10 Thread Starter
Status: -
Join Date: Oct 2010
Location: United Kingdom
County: Dorset
Posts: 9

Member car:

Alfa 147

147 Strange Light Activity!

Hi All,

Relatively new to Alfa Ownership but already finding the joy and price of driving one!!
(Having just changed the cambelt, and then needing to change all spark plugs, handbrake cable, rear drop link and still needing to change brake fluid & coolant!)

Just two odd things I have noticed, one I think I understand, and the other I dont at all!

When taking it to the garage for the work mentioned above, I also managed to get the airbag light to stay on when I was cleaning the cabin - from posts I saw here I assumed (and I think rightly) this was due to me disturbing a wire / connector under a seat. I managed to persuade the nice garage to put the car on the diagnostics and clear the airbag fault for free! And so far - 2 weeks of airbag light free driving!

However, since coming back from the garage, the passenger airbag light now extinguishes but then comes back on, flashes about 6 or 7 times then goes out. I'm not sure if it was doing this before - is this just "what it does", or is it trying to tell me there is some problem?

Another perculiarity that happens just now and again concerns the Alarm / Deterrent Light - situated on the key / lock button in the centre console. Sometimes, the light is lit when I get in and start the engine - not yellow which I know means the doors are locked, but Red - and not flashing which I know means the alarm suffered some event, but just on!
I'm sure its not an alarm indication - I know the alarm works (and so does the rest of my street ) and this light goes out after about 5 minutes of driving. Is this just an anomoly, or again, is it trying to tell me something??

Thanks for your help and experience!
MikeSki is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , activity , light , strange

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome