2.0 TS Throttle response... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 01-11-10 Thread Starter
Status: -
AO Member
Join Date: Aug 2010
Location: United Kingdom
County: -
Posts: 12

Member car:

156 TS 2.0

2.0 TS Throttle response...

Hello people!

I have a problem with my 2.0 TS 156...
It has a jerky bouncy throttle response. Other then this the car seems fine, and still pulls like a train. It can some times seem to choke up in first upon pulling off.

Someone once mentioned throttle bodies???

Any ideas?
damo494 is offline  
Sponsored Links
Status: the Alfa is re-born!
AO Member
Join Date: Apr 2010
Location: United Kingdom
County: Tyrone
Posts: 380
ecu/throttle reset?? visit that thread and see how it goes
aopa25 is offline  
Status: wondering what to tweak next...
AO Silver Member
Join Date: Sep 2007
Location: United Kingdom
County: North Yorkshire
Posts: 2,795
Images: 2

Member car:

Alfa 156 GTA

when you say "choke up" in first, do you mean "rolling in first at carpark speed, it hesitates and doesn't want to go"? if so, i had that. been fine since i switched to 99RON fuel.
aziraphale is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

response , throttle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome