No clutch - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 25-10-10 Thread Starter
Status: -
AO Silver Member
fredzedex's Avatar
Join Date: Dec 2006
Location: United Kingdom
County: Oxfordshire
Posts: 2,024
Images: 4
Help No clutch

Spent a great day driving around in the GT yesterday(barring MCSF and side light warnings)

Went to pick the wife up from work this evening,clutch pedal goes straight to the floor.............

Are we looking at major component failure or is it a linkage gone somewhere,it was fine yesterday...............
fredzedex is offline  
Sponsored Links
Status: - Update
Posts: n/a
Hopefully this is just the "R" shaped pin which holds the clutch linkage together - get under the steering column and take a look - cheap quick fix if this is the case - will have to reset the cruise if you have it.
Status: Style and Passion
AO Member
fildigger's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: Derbyshire
Posts: 786
Images: 15
This type of thing should not happen on a 21st century car !
fildigger is offline  
Status: - Update
Posts: n/a
And potentially dangerous if you happed to be driving along. One little £2.50 pin breaks and your clutch pedal and linkage end up like a pile of chicken bones.
Status: -
AO Member
Join Date: Oct 2007
Location: United Kingdom
County: Essex
Posts: 382

Member car:

brera 2.4d

Or how about ford's little money saving idea of just hooking the master cylinder pushrod over a (too short) post on the clutch pedal? Remedy is to take the pedal off, drill 2mm hole and put splitpin in. It's not just alfas........
flyingclutchman is offline  
Status: No remission for LUFC !!
AO Silver Member
ronan's Avatar
Join Date: Aug 2009
Location: Belfast
County: Down
Posts: 3,044

Member car:

156 1.8 Turismo

....happened on my Peugeot as well....all car companies are at fault !!
Why have plastic when metal will do the job ?????
ronan is offline  
Status: -
AO Member
Join Date: Jul 2009
Location: United Kingdom
County: South Yorkshire
Posts: 13

Member car:


This just happened to me in my 147 during rush hour traffic in sheffield city centre! luckily had a friend with me with the RAC. What are these pins called and where can I get one? And how do you reset the cruise control?

pslack104 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome