156 1.6 cambelt snapped - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-10-10 Thread Starter
Status: life is good ; )
AO Member
woody280's Avatar
Join Date: Oct 2010
Location: United Kingdom
County: North Yorkshire
Posts: 27
156 1.6 cambelt snapped

only had my 156 a few days the guy i bought it off said belt got done but had no receipts so i phoned the garage up that did the work, they told me it got done sept 08 at 45,000. they also told me that the old one had snapped off and had to replace pistons etc... and skim the head, the car is driving perfect can't believe its only a 1.6 so i think everything has been done properly. its now on 60,000 so i'll do belt again at around 80,000.
woody280 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Belt will be due next in sept 2011 or 81k, belt change intervals are 3 years or 36 thou miles whichever comes first

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , cambelt , snapped

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome