156 2.0 JTS Clutch judder and low engine temp - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-10-10 Thread Starter
Status: -
Join Date: Aug 2010
Location: United Kingdom
County: Surrey
Posts: 1

Member car:


156 2.0 JTS Clutch judder and low engine temp

Hi, I have recently bought a 58k 2005 156 2.0 JTS from my local Alfa garage. Beautiful to look at and sit in, but an absolute nightmare to drive in traffic. The clutch judders (a single violent judder usually) when pulling off and when slowing down in any gear at around 1500 rpm. There may be also be a slight misfire at idle.

I've also noticed that the temperature normally sits at about 60 degrees, but increases to 90 degrees in traffic until the fan cuts in.

The car came with a 1 year warrantee and 60k is not usually "old" for a clutch these days - can anyone suggest in layman's terms what might be wrong (no acronyms, please), or are both normal and indicative of the car's age?

Merrileas is offline  
Sponsored Links
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

hand car back to garage to sort judder issue out and misfire and thermostat problem

and welcome
davealfa11 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , clutch , engine , jts , judder , juddering , low , temp , temperatue

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome