dead battery. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 17-10-10 Thread Starter
Status: sellin the alfa :(
AO Member
pygmyarr's Avatar
Join Date: Jul 2010
Location: United Kingdom
County: Derbyshire
Posts: 245

Member car:

147 2.0l 3dr

dead battery.

A week or 2 ago I had my remote key fob stop working overnight. Did a search here and a thread came up suggesting I drop the car battery out for a but then yet again. It worked, all buttons worked. Not having used the car for much of the weekend (for alcohol reasons) I came to go to work this evening and it don't start, with symptoms of dead battery. I've checked It is still connected etc and all seems normal. The clock has been set back to midnight as you would expect from a dead battery,

Is there something I've missed, or is it some form of immobiliser to counter people making the battery off to stop the alarms when stealing? I find it hard to beleive that something has drained the battery over 36 or so hours....

I don't have any way of jumping it for another day or so, so ill give it a go then and see what happens.

alfa ownership = dentist visit.
expensive, sometimes painful, but at the end of the you've got a perfect grin on yer face.
pygmyarr is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

battery , dead

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome