Answers please on a postcard - Page 3 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: ALFA extremist
AO Member
Join Date: Mar 2010
Location: Australia
County: Victoria
Posts: 394

Member car:


smakster, i'd love to know... is there a way to effectively remove the pre-cat lambdas from a JTS iffin they go bad? AFAIK these things report in a 'correct' voltage range to the ecu, so could u not 'shim' out the reading using resistors and eliminate the lambdas entirely?

i'm assuming retaining the main cat and lambda would be sufficient for fueling adjustments...??

or am i totally baked ont his one?
wankski is offline  
Sponsored Links
Status: New valve in head about 2 reassemble
AO Member
Join Date: Aug 2010
Location: United Kingdom
County: Greater Manchester
Posts: 41
Images: 10

Member car:

Alfa 156 Veloce

Hmm? Is that just below the exhaust manifold and how long do you run the car for to see that ?
I suspect we have a dodgy coil pack on our TS ? Not seen that though ?
Our 156 TS taht we are fixing up just failed an MOT as it won't idle/run right still. no warning light anymore but runs rough, have sent for a set of plugs, all 8.
I have a another question, apart from the mounting plate, are the 156 1.6 coils the same as the 2.0 ones ? I would have though they were ? (I can get a set of 156 1.6L ones you see ?)
Thanks !
robertajane is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

answers , postcard

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome