Another ticking noise? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 07-10-10 Thread Starter
Status: -
AO Member
Join Date: Sep 2010
Location: United Kingdom
County: Tyne and Wear
Posts: 58

Member car:

156 2.0 JTS

Another ticking noise?

I have just had the belts,variator,water pump, new inlet camshaft and four new followers fitted. But, i have an anoying ticking noise from the engine. On first inspection i thought it was coming from the top of the engine but after sticking my head underneath i think it is coming from the bottom end. If the shells are worn do they make a noise, how bad is the noise from big ends when they let go? Mine is definatley a tick tick tick noise slightly louder when cold and not quite as bad when fully warmed up but still noticable.
Thanks for any help.
JTSDAVE is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,076
A bottom end knock from the big end bearings is usually a definite knock - not necessarily at tickover, but definitely a rasp when blipped.....

A ticking noise is more likely a sticking tappet....
rgwm is offline  
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,864
Cracked or leaking exhaust manifold?
Rockhopper is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
Usually when you have that much work done to teh engine the tappets stick for a bit. All my TS's tick for a while when I first put them back together. Smooths out over a coupel of days. The other option is the craked manafold. Had teh smae thing too. They like to crack where 2 goes to 1 and its a pain to weld.
Joss is offline  
(Post Link) post #5 of 5 Old 08-10-10 Thread Starter
Status: -
AO Member
Join Date: Sep 2010
Location: United Kingdom
County: Tyne and Wear
Posts: 58

Member car:

156 2.0 JTS

Thanks for the replies, i'll settle for any of your possible faults rather than the expense of a big end bearing job.
I will post up what the out come is after Bonello's have checked it out.
JTSDAVE is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

noise , ticking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome