Another thrmostat question - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Another thrmostat question

For those who have changed a TS 'stat in the last year or two. where did you buy your stat from, what make was it, how much did you pay for it and how long did it last?

My Intermotor one was about 35 and started to show signs of sticking in the summer. Now the weather has gone cooler it barely budges of the 50 degree mark.
Sponsored Links
Status: - Update
Posts: n/a
QH, local motorfactor 25ish, been on for 2 years now and is still ok, the same guy got me a 2.4 JTD one for 55 and they are 70+ everywhere else.

Chatting to Sonar last night and his twinnie had been running rich for over a year which Gus said had knackered the cat, a bollixed stat will probably have the same effect, as well as ruining the fuel economy, so a false economy not to change it me thinks
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
Yeah thats one of the only bits I buy spurious as they work just as well.
Joss is offline  
Status: V6 Inside
AO Silver Member
ransoman's Avatar
Join Date: Jan 2007
Location: United Kingdom
County: Aberdeenshire
Posts: 4,719
Images: 1
35 - ebspares. still good as new 2.5 years/24000 miles later.
ransoman is online now  
Status: - Update
Posts: n/a
Update time.

In the end Euro Car Parts turned out cheapest with a French Vernet part at 30.55 delivered. I've been buying parts from ECP for years and they don't usually sell tat so I thought it worth a punt.

I've just put it on and discovered that the Intermotor part I put on 2 years ago is in fact a Vernet part too, even though it came in an Intermotor box and cost nearly 10 more. This is mildly irritating given how long it lasted before but at least we've got 90 degrees on the gauge again.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

question , thrmostat

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome