147 JTD Immobilser fault? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 30-09-10 Thread Starter
Status: -
Join Date: Sep 2010
Location: United Kingdom
County: Hertfordshire
Posts: 1

Member car:

147 JTD

147 JTD Immobilser fault?


Was wondering if anyone can help me. Predicament below;

I just got back from holiday to find that my central locking was no longer working (all buttons inc. boot release)

I was able to unlock the car manually without triggering the alarm but when i turn the key in the ignition the alarm sounds but the car wont start. No lights come on and the car doesnt do anything at all. After trying this a few times the alarm now no longer sounds.

I replaced the battery about a month ago so it seems like the immobiliser maybe stuck on? Any help appreciated!
whatashambles is offline  
Sponsored Links
Status: Fixing all your keys !!
AO Silver Member
Chris's Avatar
Join Date: Mar 2001
Location: United Kingdom
County: Tyne and Wear
Posts: 3,806
Images: 2

Member car:

a very dirty car

You still get lights on even if the immobiliser is on. No dash lights is not good: your battery is flat like a pancake.
The Alarm has it's own battery which sounds like it too has also now been flattened.
Chris is offline  
Status: -
AO Member
Join Date: Apr 2010
Location: United Kingdom
County: Surrey
Posts: 137
Thanks for your reply,my car has exactly the same symptoms.I was very worried.

I used to drive my car a lot but due to changes in circumstances(work related) i now don't get to get in the car let alone drive it,once a week at most,rest of the time just sits on drive.I will make an effort and take the car out after work.
Now to charge the battery up.......
rissyone is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , fault , immobilser , jtd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome