Advice needed - cambelt snapped - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: next job: arb bushes
AO Member
Join Date: Feb 2011
Location: United Kingdom
County: West Sussex
Posts: 32

Member car:


I didn't notice the date either, but it's all interesting stuff to us noobs. What I find very Interesting is that the water pump killing the cambelt is mainly a diesel problem. Is this true ?
I hope so as it would serve them right with their interference free design, share our pain you oil burning bast........ oops, getting carried away there
Pile is offline  
Sponsored Links
Status: -
AO Silver Member
Alfafamily's Avatar
Join Date: May 2010
Location: United Kingdom
County: Warwickshire
Posts: 5,758
Images: 10
Water pump can be a problem on the V6 engine as well. As a general rule if the water pump is driven by the cam belt and it's a long complicated job, I change the pump.
Alfafamily is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

advice , cambelt , needed , snapped

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome