engine coolant tank - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-04-04 Thread Starter
Status: -
AO Member
dave 147's Avatar
Join Date: Jun 2003
Location: England
Posts: 231

Member car:

147 selespeed

engine coolant tank

i got my 147 back on friday but there was no there to tell me what had fixed the all i now is that they thought it was the oil pump which led to oil and coolant coming out of the tank there is still oil looking whater in the tank is this right am i ok to drive it i rang the garage but the service is shut (when i say tank i mean the clear tnk on the left at the front of the engin)
dave 147 is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,991
Re: engine coolant tank

It sound to me like they have done nothing!!

A problem with the "oil pump" will not cause oil & water to mix.
A problem (i.e. failure) of the oil-water heat exchanger will though.

If they had fixed the problem they sould have flushed & changed the coolant.

Don't drive it until they have fixed it properly.
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

coolant , engine , tank

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome