crankshaft sensor MCSF - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 27-09-10 Thread Starter
Status: 1st time Alfa owner and poorer for it LOL!
AO Member
Sweetcaz147's Avatar
Join Date: Apr 2010
Location: United Kingdom
County: Devon
Posts: 30

Member car:

147 JTD Lusso

Help crankshaft sensor MCSF

Hi everyone,

Just wanted to pick others brains/experiences on this one.

I had starting problems with my 147 JTD a few months back and the error code showed the Crankshaft sensor needed replacing and new one was fitted.

I have again had problems this week, my car would not start and MCSF was displayed! After jump starting it and taking it to have the code read again it is coming up with the Crankshaft sensor error again. I explained that this had already been replaced and the garage suggested that it could be the cam sensor instead. Does this ring true? I know very little about cars so any thoughts on this from more knowledgeable Alfa owners would be gratefully received.

Sweetcaz147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

crankshaft , mcsf , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome