1st major problem in my JTS - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-04-04 Thread Starter
Status: -
AO Member
mojo_jojo's Avatar
Join Date: Jun 2003
Location: Berkshire, UK
Posts: 912

Member car:

156 JTS Veloce

1st major problem in my JTS

Well, major in my books anyway. The heating in my JTS has gone mad... I now get cold, hot and oven turkey!

When the car usually starts I have it set for 20C. It slowly gets warm as usual, but after a few mins gets hotter and hotter and hotter. If I turn the heating to full (32C) and then back down to 18C, it goes down to lukewarm, but then after a few mins gets hotter and hotter again...

Even at 16.5C it feels more like 24C after a while. The only way I can get cool air is when it's on LO (below 16.5C) and with air con OFF (or ON for freezing).

Anyway car's still under warranty so I've booked it in to get it fixed in a couple of weeks. But I'm angry... makes me wonder if I was right choosing Alfa again...


mojo_jojo is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,991
Re: 1st major problem in my JTS

I had a similar problem a few years ago.
The knob for changing the direction of the airflow, although still moving, was stuck on "Max Demist" which will call for max heat too. Setting the heat setting to max cold was the only thing that would override it.
The dealer fixed it in about 5-minutes.
David C is online now  
Status: -
AO Member
RIOT's Avatar
Join Date: Mar 2004
Location: UK - West Mids
Posts: 306

Member car:

Mazda 3 Saloon

Re: 1st major problem in my JTS

Hmmm sound kinda like my 147 !!

To get cold/cool air out I have to put it on Low which automatically engages the aircon. Why it has to do that when the outside temp is -3 for example is beyond me.

If i disengage the aircon then all I get is warm air! Surely it can just get the cold air from outside
RIOT is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

1st , jts , major , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome