Alfa Romeo GT JTD problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 24-09-10 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Location: Portugal
County: Porto
Posts: 140
Alfa Romeo GT JTD problem

I'm from Portugal andproud owner of a 04 GT JTD

Well i seem to have spotted a problem in my car, the temp used to be steady at 90șc after the car had heated up now it keeps going down to around 85șC and then goes up to 90șc, this appends mainly when i cruise softly, anyone had this issue?

Thanks in advance, will take some photos of the car and do a proper introduction when i can.
Intimidator is offline  
Sponsored Links
Status: - Update
Posts: n/a
It's normal if you ask me - it goes to 85 when the fan kicks in and/or the thermostat opens, then it warms back to 90 and then it goes on again and again.
If you really want to sleep in peace, get a diagnostic cable and FiatEcuScan and check the temperature sent by the sensor. The 156 temperature gauges (don't know about GT) have a reputation of working by their own rules.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , jtd , problem , romeo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome