Connect+ A couple of questions - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Connect+ A couple of questions

Hi All,

I have a few questions about the Connect+ system in my 147.

1) How on earth do you get the voice recognition working? I can work out how to add a voice clips for entries in my phonebook but apart from 1 occasion I can't even get to the point where I can issue voice commands to the car. I hold down the button on the steering wheel and not a lot happens and sometimes I get a lady's voice saying something or other but if I say any of the commands in the manual I think it just records what I said as a memo...very odd. The manual is total **** and reads like it was written in Japanese, translated to Welsh then into Hebrew then English so isn't much help at all! Anyone that can give me idiot proof (cos I'm an idiot) step by step in structions on things like dialling by voice or controlling the sat nav that would be great!

2) Are there any software updates for the unit itself? I have the 2003 sat nav disk on order (which I think only updates the map) but dont know if that also updates the other software on the connect+ or if Magneti Marelli has released an update? (My car was born in May 2003)

Thanks in advance everyone!

Sponsored Links
Status: -
AO Member
Join Date: Mar 2004
Location: Yorkshire
Posts: 48

Member car:

Alfa 147 2.0l

Re: Connect+ A couple of questions

Have you tried ensuring that the voice recognition language is in English? - the 'hidden' menu from the main screen

I also found that the commands that it tells you in the book don't always work - I can get the following to work

list names - lists all the recordings you have made in your telephone address book
dial name - it then says - 'the name please' - say the name
dial number - it the says - 'the number please' - say '0202 etc' - end with 'dial'

hope you get it to work - it is cool once you get the hang of it!
Phillippo is offline  
Status: -
AO Member
fergie69's Avatar
Join Date: Mar 2004
Location: Sothwick, Brighton
Posts: 185

Member car:


Re: Connect+ A couple of questions

when you say you hold down the voice button , i found it works when you press it and let it go , wait for the instructions and then follow the prompts in the book , such as dial number , you'll get the hang of it eventually , and sometimes it even recognises my scottish accent.
fergie69 is offline  
Status: -
AO Member
T07's Avatar
Join Date: Nov 2002
Location: Upper Barclay. Carrow Road.
Posts: 435
Re: Connect+ A couple of questions

Mine rarely works over 20mph... too much ambient noise (which is actually very little now I've dumped those terrible F1's)
T07 is offline  
Status: -
AO Member
Chappy's Avatar
Join Date: Jan 2002
Location: Lichfield
Posts: 744
Re: Connect+ A couple of questions

You only need a short press on the button on the steering wheel. Do it for more than a few seconds and it will start recording a memo.

Tis truely great once it works.

Chappy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

connect , couple , questions

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome