Gear Stick return issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 20-09-10 Thread Starter
Status: -
Maddcatt's Avatar
Join Date: Sep 2010
Location: United Kingdom
County: Northumberland
Posts: 1

Member car:

Alfa Romeo GT

Gear Stick return issue

I'm new to this so apologies if I'm posting in the wrong place, I've read the posts I can find on this subject and I am still looking for the post from Nov 2009, the gearstick on my GT 1.9 JTD returns fine when on the drive and cold, once mobile, it stiffens up and there's no spring return anymore, making it a pain to go 2nd to 3rd or 5th to 4th as you have to return the stick to centre yourself rather than with spring assistance.

I've replaced the cable linkages but problem is still there??
Maddcatt is offline  
Sponsored Links
Status: - Update
Posts: n/a
Could be the bush on top of the gearbox needs lubing, but I'm not familiar with the layout of the 1.9JTD

Last edited by 0of0; 20-09-10 at 12:12. Reason: Spelllinng
Status: -
AO Silver Member
Join Date: Dec 2009
Location: United Kingdom
County: -
Posts: 1,171

Member car:

147 JTDM 16V

I had a look at this on the weekend because my stick doesn't return as well as it should and sometimes not at all. I looked at the bit on top of the gearbox that is supposed to get gummed up and sticky. It was as clean as a whistle inside and seemed quite free to move. It just seemed to me that the return spring force simply isn't sufficient to overcome stiction in the cables and other bits. There is some return force from the plunger on the gearbox itself but this isn't particularly strong, most of the return force seems to come from the gear stick. So possibly the gear stick bearings need cleaning up and lubing.

Incidentally, anyone know what the spring is that sits under the bolt and washer holding the up/down pivot arm on the top of the gearbox. There seems to be no relative movement between the ends of the spring when you rotate the pivot bolt, i.e it doesn't appear to do anything useful ... so why's it there ?
Alexie is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

gear , issue , return , stick

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome