156 window problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 20-09-10 Thread Starter
Status: -
Join Date: Sep 2010
Location: Ireland
County: Cork
Posts: 1

Member car:

alfa 156

156 window problems

I have an 2000 1.8 alfa 156 with front electric windows not working, back windows work fine, checked fuses and swopped switches around with no sucess. Any wiring diagram or ideas floating around.
tibo is offline  
Sponsored Links
Status: -
Join Date: Sep 2010
Location: France
County: Poitou Charente
Posts: 3

Member car:


Well Happy 156 window problems

I have just rectified a similar problem with my 1999 156 JTD.

After doing all of the things you have done - open the front door (as wide as you can) and undo the circular cover for the wires which exit the door and enter the main body.

Check that all of the 'prongs' are OK and then re-insert the plug and tighten up the cap.

Fiddly two finger job but once I had completed it the windows worked perfectly. Good luck.
cannockgirl is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , problems , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome