Tapping noise, and short in electrical system - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 18-09-10 Thread Starter
Status: -
AO Member
Join Date: Jul 2010
Location: United Kingdom
County: Northumberland
Posts: 25
Tapping noise, and short in electrical system

Hi. all.
Can anyone help???
I seem to have a tapping noise that increases when revs increase.
See pic, this is the general area that i can pin it down to, anyone got any ideas what it may be?.
alfa engine.jpg
I also have a problem where the battery is draining (New Battery) if the car is left standing for around 4 to 5 days without use.
I have used a circut tester and pulled out each fuse one by one but the light on the tester stays on, indicating that something is draining power, need help quickly with this as i am sick of re-charging the battery.
Any help with the above would be great.
Thanks in advance guys.
uplink is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

electrical , noise , short , system , tapping

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome