First Big 'Ouch' - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 16-09-10 Thread Starter
Status: -
Join Date: Mar 2010
County: -
Posts: 858

Member car:


First Big 'Ouch'

The reason for the title is that everyone (outside this circle) I tell this tale to will reply 'told you so, shouldn't have bought an Alfa'.

However my first big bill is not down to any issues with the design or build of my GT but thanks to come cack handed operative (I don't think they deserve the designation mechanic) who was allowed to work on the car by its previous owner.

I was never sure if the aircon was working properly on my car - it seemed pretty weak when I got it and gradually got worse to the point of being ineffective. I suspected a slow leak and finally got it checked out today.

Thanks to Chick at CM Garage I've now discovered that the system was indeed leaking but not in any of the usual places. The cause was that on some previous occasion someone had been working around the gear linkage cables and unclipped them from their mountings but failed to put them back (there's no way they could have worked themselves loose) and the linkage has been rubbing against the aircon pipework at the back of the engine and chafed a hole in it.

Cost of new pipework alone is 137

So, with 2 hours labour to fit (a conservative estimate but that's what Chick has quoted) plus the time to diagnose and then the standard charge for a re-gas I'm not going to get much change out of 400.

I was thinking of getting some new wheels, but that idea is kicked into the long grass now....
agent smith is offline  
Sponsored Links
Status: Married
Regional Representative
For East Midlands - AOEM
braddersR's Avatar
Join Date: Jul 2008
Location: United Kingdom
County: Leicestershire
Posts: 42,000
Images: 13
bummer lad
braddersR is offline  
Status: -
AO Platinum Member
Gary Slegg's Avatar
Join Date: Feb 2006
Location: North Wales
Posts: 16,710
Sorry to hear about that
Gary Slegg is offline  
Status: -
AO Member
Join Date: Feb 2010
Location: United Kingdom
County: Somerset
Posts: 150

Member car:

147 Selespeed

My A/C doesn't work either, I'm scared to get it looked at
Monkey Dust is offline  
(Post Link) post #5 of 6 Old 16-09-10 Thread Starter
Status: -
Join Date: Mar 2010
County: -
Posts: 858

Member car:


I would be too after what I discovered today. I genuinely thought the worst it could be was a gasket or something......
agent smith is offline  
Status: Remembering why I dislike working on old cars....
AO Silver Member
ChrisS's Avatar
Join Date: Sep 2001
Location: UK
Posts: 2,336

Member car:

166 3.0 Sporto

Probably not a great deal of consolation....but just be glad it wasn't a leaking evaporator.....

Those alloy A/C pies are pretty fragile, sadly. Same on all cars though, so no blame to Alfa.
ChrisS is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

big , ouch

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome