147 Whining noise while steering - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-09-10 Thread Starter
Status: -
Join Date: Aug 2010
Location: United Kingdom
County: East Sussex
Posts: 2

Member car:

147 2.0TS Lusso

Help 147 Whining noise while steering

Hi everyone.

I have a 2001 147 2.0ts and sometimes when I am turning the steering wheel at low speeds or when I am parking there is a sort of whining noise coming from the engine bay.

Wondering if anyone had any idea what the noise meant as i am not very mechanically minded.

Any help much appreciated!
timeout is offline  
Sponsored Links
Status: -
AO Member
hooperooy's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Gloucestershire
Posts: 167
Images: 40

Member car:

GT 3.2

probably low on power steering fluid. check and if it is low you probably have a leak. this happened to mine a few weeks ago
hooperooy is offline  
Status: -
AO Member
Join Date: Feb 2010
Location: United Kingdom
County: Essex
Posts: 301

Member car:


Check for fluid (reddish colour) around the seals - do this by removing a road wheel and have an assistant turn the strreing wheel - you are looking behind the fron wheels and the bulkhead and you will see a ribbed rubber tube - make sure there is no oil leaking from either side
alfa amore is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , noise , pump , steering , whining

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome